TYPO3 breaks on Ubuntu 8.04 LTS Hardy Heron (and how to fix it)

by on

After a dist-upgrade from Gutsy to Hardy on our webserver, TYPO3 was suddenly broken. The reason is a bug in PHP 5.2.4. There is a workaround for TYPO3, but unfortunately the patch is still pending in the core list.

Oliver Harder already requested to commit a patch and it works.

So if you run into trouble with Ubuntu 8.04, download the patch to your typo3_src directory and patch your sources:

patch  -p0 < 0006158_v2.patch



  1. Steffen

    The bug seems to affect only fcgi environments.

  2. marcus

    Thanks!! this patch worked great for me. Great job.

    btw. my env fcgi based with nginx.

Add a comment

Comments are moderated and need to approved. Please be patient.